Someone Broke My Page!

posted in Miscellaneous, Site Updates on Oct 20, 2007

I have no idea what’s happening to my front page, but it’s all skewed to the max. Obviously something is not lining up correctly, and the sidebar is going all the way to the bottom of the page. There seems to be a problem with the CSS when reading the unordered list tag for the sidebar, as there are bullets where there’s not supposed to be, but I don’t know why that would push the sidebar all the way to the bottom and make the background grey. i thought at first that the problem would lie in the CSS and how it’s handling the positioning of objects, but the more I think about it, it should be a HTML problem, or at least, the code in my Index file is wonky for some reason. The reason I’m thinking this is because you can go to any other part of my site and it works fine, and I believe archived posts have a separate file associated with them. I don’t know. And really, this just started happening out of the blue. I haven’t done anything to provoke it. I thought that there might be a problem because I hadn’t updated WordPress itself in a while, so I did that but to no avail. I have the latest update and that didn’t change anything. So we’ll see, I haven’t the foggiest right now why everything is messed up. I blame you.

UPDATE: I figured it out. Apparently I had forgotten to put a closing quotation mark in the tag on a link in the post on October 18. I’m really glad my template can explode with such little effort.

  • Jbond64

    Your template is using XHTML 1.0, which is stricter than standard HTML in how it renders.

  • I’LL XHTML YOUR TEMPLATE!